requires php ~7.1 -> your PHP version (7.0.18) does not satisfy that requirement

更新日期: 2017-09-29 阅读次数: 11547 分类: PHP

一个大兄弟本地用了 PHP 7.1 进行开发,而我本地是 PHP 7.0, 于是悲剧发生了。

composer install 之后报错

Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for doctrine/annotations v1.5.0 -> satisfiable by doctrine/annotations[v1.5.0].
    - doctrine/annotations v1.5.0 requires php ^7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
  Problem 2
    - Installation request for doctrine/cache v1.7.1 -> satisfiable by doctrine/cache[v1.7.1].
    - doctrine/cache v1.7.1 requires php ~7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
  Problem 3
    - Installation request for doctrine/collections v1.5.0 -> satisfiable by doctrine/collections[v1.5.0].
    - doctrine/collections v1.5.0 requires php ^7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
  Problem 4
    - Installation request for doctrine/common v2.8.1 -> satisfiable by doctrine/common[v2.8.1].
    - doctrine/common v2.8.1 requires php ~7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
  Problem 5
    - Installation request for doctrine/dbal v2.6.2 -> satisfiable by doctrine/dbal[v2.6.2].
    - doctrine/dbal v2.6.2 requires php ^7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
  Problem 6
    - Installation request for doctrine/instantiator 1.1.0 -> satisfiable by doctrine/instantiator[1.1.0].
    - doctrine/instantiator 1.1.0 requires php ^7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
  Problem 7
    - doctrine/annotations v1.5.0 requires php ^7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
    - doctrine/dbal v2.6.2 requires php ^7.1 -> your PHP version (7.0.18) does not satisfy that requirement.
    - doctrine/dbal 2.5.x-dev requires doctrine/common >=2.4,<2.8-dev -> satisfiable by doctrine/common[2.7.x-dev].
    - backpack/crud 3.2.21 requires doctrine/dbal ^2.5 -> satisfiable by doctrine/dbal[2.5.x-dev, v2.6.2].
    - doctrine/common 2.7.x-dev requires doctrine/annotations 1.* -> satisfiable by doctrine/annotations[v1.5.0].
    - Installation request for backpack/crud 3.2.21 -> satisfiable by backpack/crud[3.2.21].

解决方法是

删除 composer.lock 文件,重新执行 composer install,这样就能重新生成 composer.lock 文件了。

领取阿里云/腾讯云服务器优惠券

关于作者

我是来自山东烟台的一名开发者,喜欢瞎折腾,顺便记记笔记。有敢兴趣的话题,欢迎加微信 zhongwei 聊聊, 查看更多联系方式。 白天写程序,晚上哄熊孩子,可能回复有点慢,见谅。同时也欢迎关注我的微信公众号“大象工具”: 大象工具微信公众号

相关文章

爱评论不评论

近期节日

2020年10月31日 世界勤俭日
2020年11月01日 万圣节
2020年11月07日 立冬
2020年11月08日 中国记者日
2020年11月10日 世界青年节
2020年11月11日 光棍节
2020年11月14日 世界糖尿病日
2020年11月17日 国际大学生节
2020年11月20日 国际儿童日
2020年11月21日 世界问候日
2020年11月22日 小雪
2020年11月26日 感恩节
查看更多节日