Unsupported Modules Detected: Compilation is not supported for following modules: XXX

更新日期: 2019-12-27 阅读次数: 4631 字数: 94 分类: Android

在新的联想小新 Pro 13 笔记本上,安装了 Android Studio 3.5.3。但是导入已有项目时报错

Unsupported Modules Detected: Compilation is not supported for following modules: XXX. Unfortunately you can't have non-Gradle Java modules and Android-Gradle modules in one project.

解决方法

  1. 关闭当前项目
  2. 关闭 Android Studio
  3. 删除项目根目录下的 .idea 文件夹
  4. 删除所有 .iml 后缀的文件
  5. 重新打开 Android Studio,然后打开原项目即可。

爱评论不评论